curl / Docs / Releases / Vulnerabilities

curl and libcurl vulnerabilities

This table shows the 25 most recent curl versions and which releases that are vulnerable to which publicly disclosed vulnerabilities.

Each version number links a vulnerability summary for that specific release. Each vulnerability in the table header links to more details.

Green: severity low. Blue: severity medium. Red: severity high. Black: severity critical.

Version155154153152151150149148147146145144143142141140139138137136135134133132131130129128127126125124123122121120119118117116115114113112Total
8.8.0 0
8.7.1 0
8.7.0 0
8.6.0     4
8.5.0   4
8.4.0      4
8.3.0      6
8.2.1     7
8.2.0    7
8.1.2    7
8.1.1    7
8.1.0    7
8.0.1        11
8.0.0    11
7.88.1          17
7.88.0    17
7.87.0        19
7.86.0       21
7.85.0         25
7.84.0     25
7.83.1          26
7.83.0            32
7.82.0          35
7.81.0       33
7.80.0        32
7.79.1        31

See also the vulnerability table for all curl releases.