cURL / Mailing Lists / curl-library / Single Mail

curl-library

Re: curl-compilers.m4: -Wstrict-aliasing=3 for warning enabled ...

From: Guenter <lists_at_gknw.net>
Date: Fri, 29 Jun 2012 13:51:55 +0200

Hi Yang,
Am 28.06.2012 18:28, schrieb Yang Tse:
> Guenter<lists_at_gknw.net> wrote:
>
>> your commit f1474db3600172804d6f79d30e1127c6c7efa066 enables
>> -Wstrict-aliasing=3 also for clang, but it seems that clang doesnt
>> understand this warning (at least not clang 2.8 and 3.0):
>
> It seems I got fooled by existing comment in line 859 of curl-compilers.m4.
>
> Does there exist any clang version which supports -Wstrict-aliasing
> and which version is the first to support it?
>
> Same question for -Wstrict-aliasing=N and which N would be maximum one.
sorry, but I cant answer this, and cant provide any more info as I did
already; the clang 3.0 which I use on the OpenSuSE 12.1 box seems latest
of what OpenSuSE currently offers ...

# clang -v
SUSE Linux clang version 3.0 (branches/release_30 145598) (based on LLVM
3.0)
Target: x86_64-unknown-linux-gnu
Thread model: posix

# clang -dumpversion
4.2.1

here some defines which might be of interest:
./testver: __GNUC__ = 4
./testver: __GNUC_MINOR__ = 2
./testver: __GNUC_PATCHLEVEL__ = 1
./testver: __clang__ = 1
./testver: __clang_major__ = 3
./testver: __clang_minor__ = 0
./testver: __clang_patchlevel__ = 0
./testver: __llvm__ = 1

GŁn.

-------------------------------------------------------------------
List admin: http://cool.haxx.se/list/listinfo/curl-library
Etiquette: http://curl.haxx.se/mail/etiquette.html
Received on 2012-06-29