Re: naming convention of targets for Windows platform - why not use VC style?
Date: Wed, 18 Feb 2009 13:48:47 +0100
Pierre Joye wrote:
> About the configuration names, something easier to manage or use could
> be to specify which mode to use for a given dependency (for
> example,cfg=dll-debug zlib=static ssl=dll idn=dll etc.).
Looks good; that would make vc makefile much more sane.
To make it even better we could assume that debug build of libcurl uses
debug versions of dependencies and the release one uses release versions
by default. The same for static/dynamic builds. Of course giving
explicit version of some dependency would override this default behavior.
> We also use a very handy naming convention in php for the libraries,
> for example:
> DLL: libcurl.dll (and libcurl.lib)
> DLL Debug libcurl_debug.dll (and libcurl_debug.lib)
> static: libcurl_a.lib
> static debug: libcurl_a_debug.lib
The "a" suffix comes from Linux world, right?
I think we should stick to MD(d), MT(d) for Windows.
> The right library is then used depending of the active configuration
> (and if it is present).
Yep, that's the whole point of having naming convention for output
files. I raised this issue as I had problems building different targets
in curlpp which depends on libcurl.
Is there someone "in charge" of vc makefiles in the team?
Received on 2009-02-18