curl-library
Re: [PATCH 4/6] Deprecate GSS-Negotiate related macros due to bad naming
From: Daniel Stenberg <daniel_at_haxx.se>
Date: Sat, 19 Jul 2014 00:17:25 +0200 (CEST)
Date: Sat, 19 Jul 2014 00:17:25 +0200 (CEST)
On Thu, 17 Jul 2014, Michael Osipov wrote:
> case 'l': /* --negotiate */
> if(toggle) {
> - if(curlinfo->features & CURL_VERSION_GSSNEGOTIATE)
> - config->authtype |= CURLAUTH_GSSNEGOTIATE;
> + if(curlinfo->features & CURL_VERSION_GSSAPI ||
> + curlinfo->features & CURL_VERSION_SSPI)
> + config->authtype |= CURLAUTH_NEGOTIATE;
It feels strange that you want this done in patch 4 and then in patch 5 you
again change this very code again. Can you squash them instead to a single
change?
Is there a point in using both terms Negotiate and SPNEGO in symbol names if
SPNEGO is required to do Negotiate?
-- / daniel.haxx.se ------------------------------------------------------------------- List admin: http://cool.haxx.se/list/listinfo/curl-library Etiquette: http://curl.haxx.se/mail/etiquette.htmlReceived on 2014-07-19