Re: naming convention of targets for Windows platform - why not use VC style?
Date: Wed, 18 Feb 2009 10:11:52 +0100
On Wed, Feb 18, 2009 at 9:29 AM, Daniel Stenberg <daniel_at_haxx.se> wrote:
> On Wed, 18 Feb 2009, Pierre Joye wrote:
>>> Well "zlib-ssl-dll" as an example implies using zlib and ssl to create a
>>> dll. libcurlMT.dll only mentions the memory model. Wouldn't it then be
>>> called libcurl-zlib-ssl-MT.dll?
>> Windows developers are not more stupid (or less smart) than unix users.
> I don't think anyone suggested this had to do with cleverness or not
Exactly, that speaks in favor of using similar naming on all platforms :)
> It was about what to call the targets in the makefile. What is your suggestion?
What was suggested earlier looks nice:
CFG=dll-debug zlib=<zlib options> ssl=<zlib options>
for a curl DLL build with zlib and ssl support using the given options.
>> We do not have libcurl-feature1--feature2--feature3-mode1.lib/so in other
>> platforms and I fail to see why we should have it on windows.
> On almost all other platforms we run configure to setup what to build. We
> don't on Windows and thus we need a different approach! We don't need it to
> be particuarly different, we want it to be usable and understandable to
> windows builders.
The configure is somehow done in the makefile but not as developer
friendly than a true configure script :). I would like to use
something like CMake as it will let us do more fine tuned
configurations (or in a cleaner way) without relying on user inputs as
the configuration or features of a given library or compiler can be
-- Pierre http://blog.thepimp.net | http://www.libgd.orgReceived on 2009-02-18