Re: [PATCH] Make conversion of POST to GET after 301 optional
Date: Mon, 24 Sep 2007 14:17:22 -0700
Daniel Stenberg wrote:
> I'm in general favour of applying this patch. The only little thing that
> is still bouncing around in my head is the naming of the option. I'm
> thinking that perhaps we should name it somehow indicating that it makes
> libcurl's behavior more standards-compliant, but then again I guess most
> people won't even know what the standards say libcurl should do in the
> first place...
> You think CURLOPT_POST301 is a good name?
Yes - my first thought was to name it after the RFC but that leads to very
long option name that will mean even less to most people.
Something like 301RFC maybe? (RFC301 would obviously be bad :-)
Received on 2007-09-24