cURL / Mailing Lists / curl-users / Single Mail

curl-users

Re: HTTP2 support and case use

From: Daniel Stenberg <daniel_at_haxx.se>
Date: Tue, 27 Jan 2015 23:04:01 +0100 (CET)

On Tue, 27 Jan 2015, Gusano, Javier wrote:

> But when I try to use this command, CURL can't use the HTTP2 protocol:
> curl --http2 --url http://nghttp2.org
> curl: (1) Unsupported protocol
>
> ┬┐Could some one show me how to install and use CURL with HTTP2 support step
> by step?

I guess that if you do 'curl -V' on that install, you'll see that it still
loads the old (formerly installed) libcurl without HTTP2 support.

This probably because ld.so will load libcurl from the old library prior to
loading it from the lib you installed the new version in.

You can override that with LD_LIBRARY_PATH or by editing /etc/ld.so.conf or
similar.

Or maybe I guessed wrong.

-- 
  / daniel.haxx.se

-------------------------------------------------------------------
List admin: http://cool.haxx.se/list/listinfo/curl-users
FAQ: http://curl.haxx.se/docs/faq.html
Etiquette: http://curl.haxx.se/mail/etiquette.html
Received on 2015-01-27